Error syncing mcat asking final hub

Before the error happened, I was…
[requesting hub syncing]

Error message (don't change this)
Anki 23.12.1 (1a1d4d54)  (ao)
Python 3.9.15 Qt 6.5.3 PyQt 6.5.3
Platform: macOS-14.5-arm64-arm-64bit

Traceback (most recent call last):

  File "aqt.taskman", line 142, in _on_closures_pending

  File "/Users/hananm1/Library/Application Support/Anki2/addons21/1322529746/gui/menu.py", line 329, in on_done

  File "concurrent.futures._base", line 439, in result

  File "concurrent.futures._base", line 391, in __get_result

  File "/Users/hananm1/Library/Application Support/Anki2/addons21/1322529746/gui/operations/ankihub_sync.py", line 57, in sync_with_ankihub

  File "/Users/hananm1/Library/Application Support/Anki2/addons21/1322529746/ankihub_client/ankihub_client.py", line 589, in get_deck_subscriptions
    if self.should_stop_background_threads:

1322529746.ankihub_client.ankihub_client.AnkiHubHTTPError: AnkiHub request error: 406 Not Acceptable

Sentry link (for developers)

Updating the add-on from Tools > Add-ons > Check for Updates should fix the issue.

@ProductTeam I believe the add-on used to show a useful error when the add-on is outdated, but something has changed in the backend.