Cannot see "manage protected data"

I currently have v11 and I’m trying to use v12. The youtube video on AnkiHub mentions that you need to “manage protected data” before subscribing to the deck but I don’t see this as an option. Please help.

You can press subscribe to deck on AnkiHub safely and the button will appear. You should manage protected data before importing the deck to your Anki profile however.