AnkiHub incorrectly displays change when none are present

The following suggestion is displaying an addition of the tag: “#AK_Step1_v12::#Bootcamp::Reproduction::06_Pharmacology::04_Antiandrogens

However, this tag is already present on the card in Anki and when in “edit” mode.

However, when I edit an additional field like text or extra, the tag change disappears - making me think that this is a visual glitch, and AnkiHub does not know how to visually handle suggestions after they have been resolved in a subsequent query.

Possibly related to this previous post about how historical tags are displayed: Historical tag suggestions displaying inaccurately in AnkiHub

Priority: Low - this is purely a visual bug

I think this and Historical tag suggestions displaying inaccurately in AnkiHub will be solved by and the related AnkiHub PR. Is that right, @jakub.f?

I think this is actually a problem with the way the suggestion is displayed. It won’t be solved by the PR you mentioned, because this PR just changes how the tag changes are sent from the add-on to the webapp.

One PR related to this was already merged, see