Unsure what this error means and how to fix

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue to the add-on author.
Debug info:
Anki 2.1.64 (581f82c5) Python 3.9.15 Qt 6.5.0 PyQt 6.5.0
Platform: macOS-13.5-arm64-arm-64bit
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2023-08-08 13:25:30
Add-ons possibly involved: ⁨AnkiHub⁩

Caught exception:
Traceback (most recent call last):
File “”, line 28, in from_dict
File “”, line 28, in
File “”, line 9, in from_dict
mashumaro.exceptions.MissingField: Field “ah_did” of type UUID is missing in DeckExtensionConfig instance

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “aqt.progress”, line 118, in handler
File “aqt.main”, line 217, in on_window_init
File “aqt.main”, line 316, in setupProfile
File “aqt.main”, line 496, in loadProfile
File “_aqt.hooks”, line 3809, in call
File “/Users/danielpleblanc/Library/Application Support/Anki2/addons21/1322529746/entry_point.py”, line 51, in _on_profile_did_open
if not _profile_setup():
File “/Users/danielpleblanc/Library/Application Support/Anki2/addons21/1322529746/entry_point.py”, line 74, in _profile_setup
File “/Users/danielpleblanc/Library/Application Support/Anki2/addons21/1322529746/settings.py”, line 156, in setup_private_config
self._private_config = self._load_private_config()
File “/Users/danielpleblanc/Library/Application Support/Anki2/addons21/1322529746/settings.py”, line 166, in _load_private_config
result = PrivateConfig.from_dict(private_config_dict)
File “”, line 30, in from_dict
mashumaro.exceptions.InvalidFieldValue: Field “deck_extensions” of type Dict[int, DeckExtensionConfig] in PrivateConfig has invalid value {‘36’: {‘ah_did’: ‘e77aedfe-a636-40e2-8169-2fce2673187e’, ‘description’: ‘’, ‘latest_update’: ‘2023-07-26T20:59:27.717995+0000’, ‘name’: ‘UTMB_Anki’, ‘owner_id’: 6504, ‘tag_group_name’: ‘UTMB_Anki’}}

What were you doing when this error occured?

Can you try deleting the ankihub addon and see if that resolves your issue?

All I did was start anki same as normal. I tried deleting and restarting earlier and got the same error message.

Have you updated the AnkiHub addon?

Try shift-clicking when starting anki, go to tools → addons → ankihub → update

Hmm. I just tried restarting again and clicked a few different buttons. Now everything seems to be working like normal. Thanks!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.