Problems with bulk suggest notes function - repeatedly getting "failed to submit suggestions"

Hi there,

I have been playing around with AnkiHub for a few days now and I’m having ongoing issues with the bulk suggest changes function. It seems to work sporadically, but most of the time, even when I’m doing simple things like removing a particular tag from a selection of cards and then selecting all and clicking > “AnkiHub - bulk suggest notes” and submitting it to be updated without review as I’m the deck owner (have tried all the justification options including updated content, updated tags etc.) it just keeps giving me the error “failed to submit suggestions” as shown below:


It’s extremely frustrating as it only seems to work fine if I use AnkiHub on the web and manually remove the unwanted tags from individual cards and then sync with the computer. But every time the error comes up on my computer, I have to “reset local changes” and sync with AnkiHub again because otherwise all my edits are stuck locally and none of my changes are being put through to AnkiHub. It seems to work much more consistently if I’m just making edits to one or two cards. I can’t put my finger on what’s causing the issue.

EDIT: I’ve seemed to establish that it seems to work if I make additions to the cards rather than simply remove tags. Is this consistent with how its coded; that is - removal of tags or content is not considered a “change” that will sync with Ankihub?

EDIT #2: The same problem exists when removing stuff from fields; ie. the “Missed Questions” field from some cards for example that were uploaded with someone’s personal content in the MQ field; when I try and remove that and submit changes AnkiHub rejects it. I suspect this all comes down to suggested changes don’t except “deletion/removal of content” and only “addition of content or change to content”.


Removal of content is also considered a change so I wonder why it doesn’t work for you. Can you send me a link to the deck? Do you have any protected tags and fields?

Hi there - thanks for replying! Here’s the deck link: 5a1160ef-6f41-4d8c-948b-f72275ef0ff7.

I don’t have any protected tags and I’ve only just enabled the protected fields to be the “Missed Questions” and “Personal Notes” however I can still replicate the issue if I for example add some content to any field, submit changes (success) and then remove the content and submit changes (unsuccessful sync with AnkiHub).

The only way I’ve discovered to get around the issue is if I remove the content I want to get rid of and then make some other change or add a period or something to the text field and then sync. It just doesn’t seem to work if the only change is a net loss of content from anything in the card (either tags or in the fields).

I can still replicate the issue if I for example add some content to any field, submit changes (success) and then remove the content and submit changes (unsuccessful sync with AnkiHub).

Can you try syncing with AnkiHub before submitting the suggestion that removes content? (Main Anki window → AnkiHub → Sync with AnkiHub)

Here is an explanation:
The way it works is that the add-on stores a copy of the notes in the deck in its own database. When downloading updates from AnkiHub, this database gets updated. When creating a change suggestion, the contents of the note in the Anki database are compared with the contents of the note in the add-ons database and the change suggestion is only sent to AnkiHub when there are any changes.

So when you add content to a note, then remove it again and try to submit a change suggestion, the notes contents are the same as in the beginning and the add-on does not know yet that the note was updated on AnkiHub. After syncing it knows about it and you can create a suggestion that removes the content again.

Do you think that this could explain the problems you experienced?

1 Like

Ahh yes I see - my problem was I wasn’t manually syncing with AnkiHub every time before I tried submitted the suggestions. I feel very silly now. Thanks for all your help! :slight_smile: