Addon error when trying to reinstall with code and file

I am getting an error when trying to re-install. I tried the numbers and the file way. I have disabled all the add-on but to no avail. I tried the listed Anki version and the newest Anki version in two different devices but same problem.

An error occurred. Please use Tools > Check Database to see if that fixes the problem.
If problems persist, please report the problem on our support site. Please copy and paste the information below into your report.
Anki 2.1.65 (aa9a734f) Python 3.9.15 Qt 6.5.0 PyQt 6.5.0
Platform: macOS-13.5-arm64-arm-64bit
Flags: frz=True ao=False sv=3
Add-ons, last update check: 2023-08-11 22:31:19

Caught exception:
Traceback (most recent call last):
File “aqt.taskman”, line 122, in _on_closures_pending
File “aqt.taskman”, line 71, in
File “aqt.addons”, line 1186, in _download_done
File “concurrent.futures._base”, line 439, in result
File “concurrent.futures._base”, line 391, in __get_result
File “concurrent.futures.thread”, line 58, in run
File “aqt.addons”, line 1163, in
File “aqt.addons”, line 1179, in _download_all
File “aqt.addons”, line 1124, in download_and_install_addon
File “aqt.addons”, line 430, in install
File “aqt.addons”, line 473, in _install
File “zipfile”, line 1625, in extract
File “zipfile”, line 1696, in _extract_member
PermissionError: [Errno 13] Permission denied: ‘/Users/XXXXXXXX/Library/Application Support/Anki2/addons21/1322529746/user_files/’

Go to tools → addons → view files → back track one folder level, the.
Find folder 1322529746 and delete it

AnkHub Add on not installing - #4 by randysihotang see this for more information.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.