Blank Ankisthesia Cards


I’m hoping someone can help me. I cannot see the Ankisthesia cards when I go to study them (Study Now)/there is a partly blanked screen (No card, No reverse, No bottom buttons (Except Edit and More). When I press the spacebar/1,2,3,4 keys this does appear to affect the deck in terms of New and Learn but I cannot see any cards appear. The cards are visible when I Browse.

I have uninstalled, re-installed (Anki, AnkiHub, Ankisthesia Deck), removed and resynced, unsubscribed and resubscribed, rebooted, etc. I have followed the community posts on Empty Cards as well as on using the Anking Addon but to no avail. I have rebuilt and optimised the database. I have tried full screen and small screen.

Any advice would be greatly appreciated. Am on Windows 10.

Ankisthesia Deck

Study Now

Does changing the video driver from Tools > Preferences make any difference?

Sadly it does not. I have cycled through all the options (Direct3D, OpenGL, Vulkan and Software) to no avail.

Can you try this?

On Anki, go to the top left and find tools, then click on empty cards, then press delete

Have tried this, but sadly it does not resolve the issue.

Can you use AnkiHub > Help > Upload logs and data and post the filename shown?

Thank you for that. I think we’re closer to a fix. To confirm, if you disable the AnkiHub add-on (then restart Anki), do you see any change? The logs show there’s an error message that’s getting mistakenly supressed by AnkiHub, and it might be resulting in blank cards. Also, do you have the issue in the preview (Preview button in the browser) and card layouts (Cards button) screens?

OK, I managed to reproduce the issue now. Please follow the steps to fix the issue manually for now until we release a fix for the add-on:

  1. Click the Cards button to open the Card Types screen.
  2. In the Front and Back templates, search for tts and remove the line highlighted in the screenshots:

  3. Click Save.

@jakub.f the add-on is suppressing backend errors, which is resulting here in blank cards and incomplete rendering of the review screen. Specifically, the issue here is that the following TTS-related error is thrown:

anki.errors.BackendError: WindowsError { details: Other, source: Error { code: HRESULT(0x80070002), message: "The system cannot find the file specified." } }

The add-on is logging that in _try_handle_exception() and some routine is probably failing to propagate it.

1 Like

Thank you so much, that fixes the issue.
Appreciate the help.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.