Got this error message

Whenever I open Anki I got this message, I tried updating ankihub add-on but nothing working

Hold shift while starting Anki, then go to tools-> addons and check for updates. Then restart.

Does that work? If not it looks like it’s the anking note types addon so please post the full error code on that GitHub https://github.com/AnKingMed/AnKing-Note-Types

the hold shift did not work. Can you please explain what you mean with the code on github?

this is the full message:
Error
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue to the add-on author.
Debug info:
Anki 2.1.54 (b6a7760c) Python 3.9.7 Qt 6.3.1 PyQt 6.3.1
Platform: Mac 11.6.5
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2023-04-29 00:50:35
Add-ons possibly involved: ⁨AnKing Note Types Easy Customization⁩

Caught exception:
Traceback (most recent call last):
File “aqt.progress”, line 118, in handler
File “aqt.main”, line 197, in on_window_init
File “aqt.main”, line 290, in setupProfile
File “aqt.main”, line 470, in loadProfile
File “aqt.hooks_gen”, line 3244, in call
File “/Users/mkriv/Library/Application Support/Anki2/addons21/952691989/init.py”, line 36, in on_profile_did_open
maybe_show_notetypes_update_notice()
File “/Users/mkriv/Library/Application Support/Anki2/addons21/952691989/init.py”, line 63, in maybe_show_notetypes_update_notice
models_with_updates = models_with_available_updates()
File “/Users/mkriv/Library/Application Support/Anki2/addons21/952691989/gui/config_window.py”, line 558, in models_with_available_updates
return [
File “/Users/mkriv/Library/Application Support/Anki2/addons21/952691989/gui/config_window.py”, line 562, in
if _new_version_available_for_model(model)
File “/Users/mkriv/Library/Application Support/Anki2/addons21/952691989/gui/config_window.py”, line 569, in _new_version_available_for_model
newest_version = note_type_version(anking_notetype_model(base_name))
File “/Users/mkriv/Library/Application Support/Anki2/addons21/952691989/notetype_setting_definitions.py”, line 595, in anking_notetype_model
(ANKING_NOTETYPES_PATH / notetype_name / f"{notetype_name}.json").read_text()
TypeError: unsupported operand type(s) for /: ‘PosixPath’ and ‘NoneType’

Go to that GitHub link, click the “issues” tab and then post the error code there with details about what triggers it

It happened to me so I uninstalled and then re-installed Ankihub and it worked.

did not fix for me

@jakub.f any idea what’s going on here?

I had to re-install Anking Med customization add-on, now it is all fixed, thank you for the help!

1 Like

I just released a new version of the AnKing note types add-on with a fix.
It had to do with copies of AnKing note types (the ones looking like AnKingDerm-30f97) not getting recognized.

1 Like

Was the add on , 1322529746? I tried this 2x and its getting the same error message. I did the updating on the tools menu and it deleted the AnkiHub from my add ons. :frowning:

The error can be fixed by updating the AnKing note types add-on if you have it. You don’t need to uninstall the AnkiHub add-on.

Now that it is uninstalled, you can install it again using the code.

Yes, that’s the code of the AnkiHub add-on.

Alternatively you can install the add-on from here: 🎬 Get Started -

Edit: This was solved, see Previously had AnkiHub and now I can't instal it after the bug - #6 by scattyzay

I’m still having trouble after updating Anki, and trying to install.

I keep getting this error code

Error
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue to the add-on author.
Debug info:
Anki 2.1.56 (07fd88dd) Python 3.9.15 Qt 6.3.2 PyQt 6.3.1
Platform: macOS-13.3.1-arm64-arm-64bit
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2023-05-01 18:38:48
Add-ons possibly involved: ⁨1322529746⁩

Caught exception:
Traceback (most recent call last):
File “aqt.main”, line 1819, in onAppMsg
File “aqt.main”, line 1250, in installAddon
File “aqt.addons”, line 1683, in installAddonPackages
File “aqt.addons”, line 502, in processPackages
File “aqt.addons”, line 430, in install
File “aqt.addons”, line 471, in _install
File “zipfile”, line 1625, in extract
File “zipfile”, line 1696, in _extract_member
PermissionError: [Errno 13] Permission denied: ‘/Users/Zay/Library/Application Support/Anki2/addons21/1322529746/user_files/README.md’

Any ideas?
Pondering Anthony Anderson GIF by BET