Not Seeing Bluelink Anki Deck After Subscribing

Before the error happened, I was…

I am unable to see cards from Bluelink after subscribing via AnkiHub (See attached images).

I tried resetting my local changes after looking at the forum, but am unable to find the AnkiHub Add On tab. Any kind of help would be greatly appreciated, thanks!


Error message (don't change this)
Anki 23.10 (51a10f09) Python 3.9.15 Qt 6.5.3 PyQt 6.5.3
Platform: macOS-14.0-x86_64-i386-64bit
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2023-11-10 23:02:20

Traceback (most recent call last):

  File "aqt.taskman", line 138, in _on_closures_pending

  File "aqt.taskman", line 82, in <lambda>

  File "aqt.taskman", line 102, in wrapped_done

  File "aqt.operations", line 127, in wrapped_done

  File "aqt.addcards", line 296, in on_success

  File "_aqt.hooks", line 40, in __call__

  File "/Users/hbb/Library/Application Support/Anki2/addons21/1322529746/gui/", line 100, in on_did_add_note
    open_suggestion_dialog_for_note(note, parent=editor.widget)

  File "/Users/hbb/Library/Application Support/Anki2/addons21/1322529746/gui/", line 84, in open_suggestion_dialog_for_note
    ah_did = _determine_ah_did_for_nids_to_be_suggested([], parent)

  File "/Users/hbb/Library/Application Support/Anki2/addons21/1322529746/gui/", line 178, in _determine_ah_did_for_nids_to_be_suggested
    _debug_issue_with_determining_ah_did_for_nids(e, anki_nids)  # pragma: no cover

  File "/Users/hbb/Library/Application Support/Anki2/addons21/1322529746/gui/", line 220, in _debug_issue_with_determining_ah_did_for_nids
    raise e

  File "/Users/hbb/Library/Application Support/Anki2/addons21/1322529746/gui/", line 174, in _determine_ah_did_for_nids_to_be_suggested
    dids_that_all_notes_could_belong_to = set.intersection(

TypeError: descriptor 'intersection' for 'set' objects doesn't apply to a 'NoneType' object

Sentry link (for developers)

When prompted, did you click upload to ankiweb?

I do not remember seeing that prompt. Is that when I subscribe on the website or when I sync my Anki deck on the app?

Sorry for the late reply, this is when you sync in the anki app

Whenever I click sync in the Anki app I am not seeing a prompt. I see a small window that says “syncing…” and then a small message in the bottom right hand part of the screen that says “sync complete.”


Following up on this. Is there anything I can do to fix this issue?

Can you go to AnkiHub > Help > Upload logs and data and post the filename shown?


Thank you for the response! Could you direct me to where I can find the AnkiHub dropdown menu? I can’t find it on my toolbar (see attached images).

You must first download the ankihub addon, go to tools at the top left → addons → get addons → paste this code: 1322529746

After that, click sync and it will prompt you to install the bluelinks deck. After installing, click sync and click upload to ankiweb when prompted

This worked! I am now able to see the cards.

Thank you very much, I really appreciate it!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.