Sketchy images will not appear in the cards despite being in the folder

I imported all the media as shown on the original youtube video. However many of the media despite being in the media collection aren’t being detected by the relevant cards. For an example, based on the screenshots below you can see one of the sketchy images in the media folder, but on the relevant card, that image is not visible. This is the case with any of the sketchy cards in this deck. How can I get anki to connect the correct cards with the correct images? Thank you

The Sketchy field is empty in your collection. There is no reference to an image. The exact same note you used as example has some images in the Sketchy field.

SW GNAQ_1566160514431.jpg
Zoverall picture (97)_1566160514431.JPG

Perhaos you are protecting fields? or you did when updating.

1 Like

Thank you for the reply. Would the solution be to unsubscribe, delete and resubscribe and make sure the protected fields are unchecked?

The solution is to uncheck Sketchy as a protected field on AnkiHub, unsubscribe, resubscribe, and reimport the media file. Let me know if that works. @UncleMozilla


That seems to have solved the issue. Somehow I had accidentally ticked all the boxes as protected fields within AnkiHub site. Thank you so much!

Perfect. The useful ones to tick are lecture notes, missed questions, pathoma, b&b, physeo, & pixorize

I have same problem,but I remember that I didn’t protect sketchy field ,so what should I do?
re-import media?