AnkiHub is not syncing

The category for general support questions related to using AnkiHub.

Please include supporting information and documents such as screenshots, recordings, error messages, etc.

I have not been able to sync with AnkiHub in a while. I have deleted and re-installed the add; however, it was no help.

I’m not sure where to find my private config that @andrew requested. However, I have included an error message I recently got below.

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue to the add-on author.
Debug info:
Anki 2.1.55 (01caec2a) Python 3.9.15 Qt 6.4.0 PyQt 6.4.0
Platform: Windows-10-10.0.22621
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2023-01-15 22:12:42

Caught exception:
Traceback (most recent call last):
File “aqt.taskman”, line 122, in _on_closures_pending
File “aqt.taskman”, line 71, in
File “aqt.taskman”, line 90, in wrapped_done
File “aqt.sync”, line 97, in on_future_done
File “anki.dbproxy”, line 36, in begin
File “anki._backend”, line 92, in db_begin
File “anki._backend”, line 108, in _db_command
anki.errors.DBError: DbError { info: “SqliteFailure(Error { code: Unknown, extended_code: 1 }, Some("cannot start a transaction within a transaction"))”, kind: Other }

Hi, @amardash ! Thanks for joining the new forum and sharing that error message :slight_smile: We’ll take a look at this and get back to you ASAP.

In the mean time, can you use the add-on help menu to upload your logs?

Hi @andrew ! I really appreciate your prompt response and all you do for us AnkiHub members. I have uploaded my logs and have the related info below.


Hello! I am having the same issue. A friend and I are trying to add cards to our new AnkiHub collaborative deck, but as we are syncing, we cannot see our changes to the deck on the AnkiHub website or on each other’s personal Anki accounts. Please keep me in the loop with any solutions!

Here are some screenshots, and I will also upload my log.

As you can see, there are 10 cards on my app that are not showing up on the AnkiHub online collabortive deck, even after syncing.

Can you try disabling the amboss add-on and see if it works then?

1 Like

Can you also try to sync manually by clicking on the “Sync with AnkiHub” action in the AnkiHub menu on the main Anki window if you haven’t tried that? What happens when you do that?

Hello, I am having the same issue. Many of my tags are missing and I have gotten no new updates since I subscribed to the Anking Overhaul Deck. Tried unsubscribing/resubscribing several times. I just reinstalled the add-on and that didn’t help either. I’ve tried manually syncing and I don’t believe any of my add-ons are the problem.


Hi @jakub.f ! My “Sync with AnkiHub” is normally grey so I’m not able to. I have included a screen shot for your reference. This is also after I disabled the amboss add-on per you suggestion!

I think this may be because you haven’t uploaded your new cards. When you make new cards, they don’t automatically upload. You’ll need to select them in the browser and then right click and select “bulk suggest notes”. You can check the box to upload as a maintainer since you’re the deck owner. You can also do notes one by one when you’re making them by clicking the box to suggest new note in the editor

Does that resolve the issue you’re having?

1 Like

@ellarmeyer , @catherinetrad please create a new support topic if either of you are still having issues and we’ll help you out ASAP! Also, please let us know if the answer above solves the issue you were having.