"ankihub_protect::All" is not protecting all my cards

Hey folks -
Ok, my frustration has gotten the best of me. Approximately 5% of my cards somehow mysteriously lose their “Ankihub_protect::All” tag.

At some point in my pre-clinical journey I decided - because of the insane amount of customizating I do to each sweet, precious card - to “protect::All” whenever I unlock a group (i.e., a specific tag) of cards for the first time. So, I do it every time. I make the font uniform, add my images from my notes, and get everything just like I want it, and then Control+A → then “Add tag” → “Ankihub_protect::All” to the entire group.

There is no rhyme nor reason to when or where or why. It can be a card that I haven’t seen in a month or 6 months, or it can be a card I just unlocked this week. All of the other cards from that tag still have all of their customized edits, but 5% (-ish) of my cards lose all of my notes and changes and font perfecting and are back to appearing like the cards do before I make the changes. I’ll open the card up, scroll down, and voila, no “protect::All” tag. Please know if a card I’ve gotten right 4 or 5 times was unlocked by me and somehow escaped my editing, it would have never made it 4 or 5 rounds without me stopping down and fixing the fonts at least. In other words it these cards lose their “protect::All” tag while they’re waiting their turn in the algorithm.
My subjective (and otherwise completely baseless) observation is it seems like I was having this issue between 6 month and a year ago, then it went away, and this past week it’s been rampant. (yes, in my OC(P)D head losing all theat time and effort and being distracted and stopped down by everything not being uniform on 15-20 cards out of 400 reviews is “rampant”)

So, any info on this would be appreciated. I guess every morning I can go in and re-tag all my unlocked cards but that’s kind of defeating the point of having the “protect::All” tag in the first place.


The tag is case-sensitive. Are you sure you are using this exact tag? “AnkiHub_Protect::All”

If it has a lower-case letter at the start of the word, it will not work

Ankihub_protect::All = will not work
Ankihub_Protect:All = will not work because the H in ankihub is not capitalized
AnkiHub_Protect::All = will work

See this for more information

I have been using: ankihub_protect::All

just like that - all lower case before the two colons. I was using that because that (i.e., “ankihub_protect”) is the “parent” that populates when I start typing to add the tag, thinking that’s what the #AK_Step1_v12 deck was “suggesting” was the correct form of the tag. But as I go back and dig into my tags along the lefthand side, I realize all of the tags that I know are from the #AK_Step1_v12 deck, for example, “AnkiHub_ImageReady” are capital A, capital H “AnkiHub” and the first letter of every word after the underscore is also capitalized (e.g., AnkiHub_Deleted). It is only the “ankihub_protect” parent tag that is all lowercase. So I’m guessing “ankihub_protect” is a parent tag I created when I first started playing with the idea of protecting my fields and anki has just been “suggesting” I use it ever since.

So, three things:

1.) First, thank you for reiterating this and telling me this again (you’ve told me this before when something similar happened to me regarding a tagging issue). I have always just assumed that the “suggested” tags that populate when I start typing were coming from Ankihub, not from my previously (mis)typed/mis-capitalized tags.

2.) I think this is a problem that’s pretty easily fixed man (here comes an opinion you didn’t ask for) - if y’all will add the correct tags (e.g., “AnkiHub_Protect::Text” and “AnkiHub_Protect::All”) to the tags on the lefthand side, even though they’re not actually assigned to any cards, when someone decides to add a tag to protect a field, the corrrectly formatted tag will populate as the suggestion. It seems like that would prevent this from happening a vast majority of the time.

3.) Last thing: it’s not entirely true that “ankihub_protect::All” will not work at all - for whatever reason, it actually does work 95% of the time. Admittedly I don’t understand all of the programming variables influencing this/at play here, but it seems to me that it’d make everybody’s life easier - including y’alls - if y’all just went ahead and included all - or at least the major - caps/no caps iterations of “AnkiHub_Protect::All/Text” so that it’s case insensitive and works 100% of the time instead of 95%.

Again, I appreciate it dude, I’m going to go straighten out all of my “ankihub_protect” tags and hopefully that’ll fix things - I’m fairly sure it will!

1 Like

All kinds of special AnkiHub tags should be treated in a case-insensitive manner, because that’s how Anki treats them.

@ProductTeam maybe we can review all special tags in the add-on/website to make sure they work as expected?

1 Like

intuitively, this is how I would have thought it would’ve worked as well, but obviously that’s not the case.

Morning guys I wanted to share an update that I think might be pertinent.

I thought I made all the changes to the “ankihub_protect” tag from my PC laptop, but this morning I realized that I’d forgotten to make the changes to this small temporary deck I’d made before my last test so I could get to them easily. I was doing cards on my iPad and have recently learned how to make changes from within the app on my iPad so I just went in and selected them all and added the “AnkiHub_Protect::All” tag. I changed them all, and yet interestingly, I’d say half of them still showed the “ankihhub_protect::All” tag. So, I was like, "Ok, maybe I have to delete that tag entirely before it’ll create the new tag. So, I selected them all again, and deleted the lowercase version. Then went back a second time and selected all, add tag, “AnkiHub_Protect::All.” The iPad STILL didn’t give a sh*t that I’d tried to erase the lowercase version of the tag. It still listed at least half - though not all - as “ankihub_protect::All”

So, while the lowercase tag is completely gone from my list on the lefthand side on my PC, I’m guessing the lowercase tag on the iPad/app was the first one I created and the app is “thinking” that it shouldn’t/doesn’t matter whether or not the tag is capitalized and therefore it’s continuing to change even the correctly “AnkiHub_Protect::All” entered tags back to the all lowercase originial version.

So, is there perhaps a difference in the way the app interprets capital letters on tags vs the way the PC interprets them? B/c then that would make sense to me that updates are interpreted differently, depending on whether or not I’m on my PC or iPad when they come down the pipeline.

To be clear, I have absolutely NO idea what I’m talking about, but it just seemed pertinent and I wanted to let y’all know the discrepancy I discovered.

Hope this helps!

Ok sorry y’all one more thing: I just went back to my PC and checked the small deck of cards that I tried 3 different times to add the correctly capitalized “AnkiHub_Protect::All” tags to and despite having changed them to the correct form on my iPad, the iPad still uploaded those changes to the website as “ankihub_protect::All” - so even though I corrected them, they were uploaded incorrectly from the Ipad. So, yeah, there’s something off between app vs website. :+1: :man_shrugging:

After removing the tag from all notes, make sure to use Tools > Check Database, then add the tag with the correct capitalization back.