Images not being synced/Weird sync delay with images

Lately, there have been a few images when accepted that do not sync.

For example, the image here 21090476-b119-4f66-ad77-b901899c84fa and here nid:1537180243091.

We have tried screenshotting and suggesting and that also does not work. You can see the AnkiHub history for nid:1537180243091 and me and @CTE_BrainDamage have tried fixing it but it does not show up. Usually, screenshotting the image fixes it, but this is the first time even after screenshotting the image does not sync. Its seemingly random as well

UPDATE: We can all see nid:1537180243091 now but it took a day until it worked.

Occurrence #2: Also noticed this with one of Ahmed Afifi’s new images he illustrated regarding heteroplasmy with nid:1469146878242. I accepted the image a few days ago, then realized it was not syncing. Then i checked yesterday and it showed up.

I am suspecting there is some sort of lag between images being accepted and actually showing up for users. I cannot estimate the lag or even if there is a lag, but images that don’t show up yesterday for a maintainer, magically show up today for some reason with nothing changed

I just changed this cards image to a screenshot (21090476-b119-4f66-ad77-b901899c84fa) and no one can see it except @herstein.jacob. However when I reset local changes I can see it. I suspect tomorrow everyone will be able to see it.

@developers do you know what is going on?

1 Like

An image on a note added today “nid:1686760718841” is also not syncing properly despite trying to fix it as noted above

1 Like

I can confirm I have the same issue as well

Added needs-dev-team

For media to appear in Anki you have to sync with AnkiHub and then wait until the download is done in the background. You can check on the status of the download by looking at the “Media Sync” menu item in the AnkiHub menu. It says Media Sync: Downloading... when media files are being downloaded and Media Sync: Idle when it’s done.

If the image still doesn’t appear after you sync and media sync is idle, please upload your logs by clicking on AnkiHub → Help → Upload logs and post the log filename here.

Note that some fields are excluded from media sync in the AnKing decks. For other decks, please check if the media files show up on the note on the website. If not, then the image wasn’t uploaded and the add-on can’t download it either.

1 Like


Missing: 2bfaee6df64a28dc802483a19aa9806c.JPG
Missing: 37dec9debc8e6a02cad1b2a03f1e5f1b.jpg
Missing: 52e45b38a0f9b04cdd9473574f40701b.jpg
Missing: 75c564f977cef729350f15cd3b0dbcbf.jpg
Missing: 7c59b489839f5a46c0fac4710c0ee0f3.jpg
Missing: 88b8ad128e1e624834d1db1fa4e2ae1f.jpg
Missing: ab7ff86b13c1cff33a87b4dd73002dcf.jpg
Missing: c6224c2ea3f0c7f29a7dc25af3be4fe4.png
Missing: eef81e619ac473c00acb6f4c6459a29d.jpg
Missing: fa0b8781e759841547d2eed4a4c5515e.jpg
Missing: fc3130af191fd0939b74c0689f7d86e3.JPG
1 Like

Whats interesting is when I try to fix them by screenshotting original picture and resubmitting, I can see them even after resetting local changes, but others still cant see it. Usually when resetting local changes I would not be able to see it.

nid:1678812591398 and nid:1680109090322 are still not showing for me despite waiting for media sync to go to idle.

The note I mentioned above (nid:1686760718841) has since begun to show up in my collection, seems it was edited/resized earlier today.

Logs: ankihub_addon_logs_a075e_1693887843.log

1 Like

These two notes, corresponding to nid:1678812591398 and nid:1680109090322 in the AnKing Overhaul for Step 1 & 2 deck only have images which are not available even on the website. So the add-on can’t use them either. To me it seems that there is no problem with the media sync here.

Can you please upload your logs once more when you encounter the issue again? The new add-on version, released yesterday, will log more information that will help with diagnosing the issue.

Also, it would be helpful to know the deck to which the notes with missing images belong.

Note that if an image isn’t visible on the website, the add-on won’t download it either.

All the missingnimages we are reporting for is the AnKing overhaul for step 1 and 2