Maintainer Deleted optional tags

As a Maintainer of an optional Tag group, I have updated some tags by Removing them entirely from cards. Even though I removed them they are still appearing as tags to another user/maintainer. Despite both of us syncing with the hub and even using the “reset an optional tag group” in the browser they still were tagged for them. It seems as if updating cards with added/ edited tags is working just not the removal of tags from user to user.

I don’t know if it has anything to do with this similar yet opposite issue:

What if the other user unsubscribes and re-subscribes to the optional tag group, does this still occur?

Yes, it does. I’ve confirmed that unsubscribing and resubscribing does not fix it for me or others. It also happens to me when other maintainers delete tags or change tag names. I get the new tag but the old tag stays.
I have found resetting the optional tag group helped me but having to reset it every time I want to update my optional tags is tedious, and time-consuming.

Currently the reset tag option is the only way as far as I know.

I think you can also use this clear unused tag button from the fastbar addon, might be helpful as well

CleanShot 2023-08-23 at 18.52.03@2x

It appears that deleting optional tags from specific notes only works if you suggest a note change that also contains a different change other than deleting the optional tag. (Doesn’t seem to be true - I made a mistake while testing).

@jakub.f what’s the intended behavior here? Shouldn’t the add-on allow suggesting optional tag deletion? (Not sure how that’s handled in the frontend currently, though)

Unfortunately removing optional tags is not supported yet. We have this on our list of things to do.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.