I loaded the images from google drive, but key images seem to be missing

Anki id: 1426098922504

I even loaded the pictures from V11 but again, missing. Where can I find the extra images?
Thank you.

In V11, the picture is there, but when I update to V12 using ankihub, its missing.

Answered in this post.

I’m not quite sure I understand.
On the reddit post I see:

The deck may include html that references images found in earlier versions of the deck with undetermined rights to use and as such may not include a useable image. We are actively working to replace everything in the deck with better images that we have permissions to share. While other images are available in social media (e.g., Reddit posts and comments or other public forums, we are not connected with and do not maintain or otherwise affiliate with these other sources.)

I understand that images that may be copyrighted are not included in the new media pack. However, upgrading from V11 (when I had the images) deletes the images and replaces it with nothing. How do I keep the images?

You need to use the AnkiHub > import media function using the media linked in the post I just sent. That will add all the correct media into V12.

Then it’s a bug report I guess!
On Mac OS (intel), Version ⁨2.1.60 (76d88073)⁩ Python 3.9.15 Qt 6.3.2 PyQt 6.3.1

  1. Starting from a fresh install of V11 obtained from Reddit with Media.
    Obtain this:

    Where pictures are loaded.

  2. Through ankihub addon, downloaded most recent AnKing deck.

  3. Downloaded additional media through MEGA. (also tried with ZIP direct download, same result).

  4. Picture that was there before is now gone

Is this a known bug?

No, this should not be happening. Try the following:

  1. Delete all cards that have V11 as the head tag in browse
  2. Tools > empty cards > uncheck keep > delete
  3. Tools > check media > delete unused
  4. Unsubscribe to the AnKing deck via the add-on > resubscribe (don’t delete the deck)
  5. (optional) Download and import a media pack (see here for details)

Let me know if this works

It seems a lot of those are known as they have the “ImageFix” tag.

Looking at the HTML of the images in these boxes, the file name is NOT present in “AnKing v12 copyright free images.zip” found in the Reddit comment. Hence it does load when importing the media.

From V11:

name: paste-5742371275045-4d12d03d91e7a4b9554ba1afa11b0d565fd2d111.jpg

From V12:

name: paste-5742371275045.jpg

| File name was cut, so the image no longer matches the name in the media folder.


Is another example.
V11 Media had name “tmpkkWKcb-9ed2099fa50135ad81972b23aec4f196e60eb8e0.png”
And was changed to “tmpkkWKcb.png”, leading to an absent image.

After importing V12 and V12 media from Reddit:
Missing files: ⁨23135⁩
Unused files: ⁨38⁩

After importing V11 media:
Missing files: ⁨20036⁩
Unused files: ⁨3878⁩

After changing all names that matched the following regex r"(.*)-([0-9a-z]{40}).([0-9a-z]+)"
Missing files: ⁨8183⁩
Unused files: ⁨3914⁩

After batch edit to remove Physeo media and Pixorize media fields
Missing files: ⁨247⁩
Unused files: ⁨3915⁩

There is 800 cards still with missing media.

the actual images are the shorter ones. I’m not sure why your collection is messed up, but it may be due to weird updates in the past.

I’d backup before trying this solution (Anki: How to Backup and Restore From Backup: Anki: How to Backup and Restore From Backup - YouTube)

  1. use the batch edit add-on. Delete all contents in every field on V11
  2. Check media and delete all unused media (should be a ton)
  3. update to v12
  4. import media

I am also having this same issue. This same image is missing in mine. I often get a question asking “what is this an image of?” and I see no image. I have ankihub, I downloaded my media from here: Reddit - Dive into anything . A lot of images were imported! I would say most of my images are there, but a few very key images are missing.

Can you provide the nid’s of the cards missing images? There is currently a bug with new images we are trying to solve