Upgraded to V12 today–all images in 'extra' field are missing

Any extra field with images in it is not displaying media and is instead displaying the icon in the examples above. I subscribed to ankihub and Anking V12 today, synced through ankihub, have tried importing the media manually through the google drive link in the reddit post–none of this seems to have worked. I’m quite overwhelmed right now as anki is my main method of studying. If anyone has advice or a fix I would greatly appreciate it! Thanks for your help.

1 Like

Hey, can you please check if your PC is still syncing images from the site, click on the Ankihub addon and see “media sync” status.

I did not update to V12 today and am having the same issue. My media sync status is idle. How would I correct this? Thanks in advance!

Please try resetting your local changes. To do this:

Go to browse in your Anki > at the top click on ankihub addon tab > press reset all local changes

Then sync again and see the media sync status.

Thank you for getting back to me! I was able to do what you said but unfortunately the media sync is still idle. What should I do next?

Can you go through all the steps you took to install V12?

The text and extra images are synced via AnkiHub so you should be able to see them after installing.

When prompted, did you press upload to ankiweb or download from ankiweb?

@aaron.therien, kindly unsubscribe and resubscribe to the deck and then try to sync again, if that doesn’t work then kindly go to tools > check media and tell me how many files are showing as missing.

Seems he has the right deck? Saying from the fact that the image has our photo credit text in it @Ahmed7

@Ahmed7 I have had V12 installed for over 1 year and I haven’t had this issue before. When prompted I pressed download from Ankiweb.
@Stillmatic I unsubscribed, resubscribed, and synced, but am still having issues with the Extra field media. When I ‘Check Media’, this is my readout:

Trash folder: ⁨⁨96⁩ files, ⁨67.18⁩MB⁩

Missing files: ⁨11717⁩

Unused files: ⁨1829⁩

A couple minutes ago, I got a pop-up window that an AnkiHub add-on error has occurred. I asked for the error details and my request in processing.

Please post that, also if you are able to, upload the log file here;

Anki window → AnkiHub → Help → Upload logs

Unfortunately, my request was stuck processing and did not compile. My log file is below:


Thank you for your response! I followed all of the steps to update from v11 to v12 which were on the ankihub.net website. When prompted I pressed download from ankiweb. It seems like my decks are syncing with ankihub still but interestingly when I view the cards missing media in ankihub, ankihub doesn’t seem to have the images either:

@Stillmatic media sync is idle and does not change when I press that button. I have also attempted resetting local changes, to no avail.

1 Like

I have the same issue. Followed all the steps to convert from V11 to V12, tried resetting local changes, unsubscribe and resubscribed. AnkiHub also shows “Image not available”, but if I look at note history, I see a picture that was accepted, which I’m assuming should display on my card in the Extra section.


@jakub.f @andrew can you please have a look at this.
I think we also had an issue where some images were not syncing for the new cards? Might be a bug?

@e43356754 Images not showing on ankihub is normal, only maintainers can see those images. I see the card already has an ankihub_imageready tag so the images should sync.

1 Like

When updating to v12, you must press “upload to ankiweb”

@ymh @aaron.therien @e43356754

1 Like

How many images are you missing? If its a less than 30 then thats because of a new bug. But if you are missing 1,000’s then that is not intended.

If you upload to ankiweb → and reset local changes. You will see the images in text and extra fields.

Please note we do not sync first aid and additional resources, so you will not see those images without a media package. Please let us know what images you are missing so we can further diagnose the issue

Can you check if your on the latest anki version and if you are, try reinstalling the ankihub addon.

This Issue probably needs to be merged here @Ahmed7

1 Like

A post was merged into an existing topic: Can’t Find Missing Media