Can’t Find Missing Media


I’ve noticed that even though I downloaded the media file, and sync with ankihub, I still have missing media. I feel like this is the wikimedia stuff, as shown in the pictures attached. I tried redownloading the media files from the links and it gave me the message that no new media was added. AnkiHub media sync is also always on idle. How can I get these last files, because it’s honestly very annoying.


These images are not from the media file.

Can you try resetting your local changes?

Go anki browse → ankihub addon at the top → reset local changes to deck

Thank you. Did this and AnkiHub downloaded the rest of the media.

Hello, I am having the same issue and I tried the solution but it did not work.
I’m missing approximately 3k images the same way s11940831 shared photos of.

Are these text and extra images?

We are syncing those so if you cannot see them.

Please try resetting your local changes. To do this:

Go to browse in your Anki → at the top click on ankihub addon tab → press reset all local changes

This will restore everything to what AnkiHub has unless you have specifically protected those fields

I am having the same issue. I tried resetting local changes, unsubscribing and resubscribing with no solution. I tried importing images from meta, however none were uploaded because it says I currently have all the images. When I check media I am missing 3k images. I have the images in the first aid/sketchy, but they do not appear in the question stem or extra block. What is the next step?

We are currently not syncing media for the text and extra fields. However we will do that soon. See Images not being synced/Weird sync delay with images - #15 by Ahmed7

1 Like

I have the latest anki version, reinstalled ankihub addon, reset local changes, imported media (no cards images added because it says I have all the images), when I check media I am missing around 3k cards. I pressed “upload to ankiweb” when installing the deck.

Please see above for the answer by @jakub.f

1 Like

Ok, I know my classmates that just switched for V12 a few days ago have those images for the text and extra fields.

It takes time for the media to download. Whats your media sync saying? Text and extra are not influenced by the media package as well

Media sync says downloading when I hit sync but then goes to Idle. It took awhile to download when I first downloaded V12. I am under the impression that I am waiting until admin syncs the images for Text and Extra block.

Am I suppose to do anything to get these images or do I wait (according to @jakub.f above message)?

You will just have to wait, we will let you know when this gets done. Sorry for the inconvenience!

They might have gotten the images using a different method.

I need this method, I’m sending cards in the future that I cannot see the text picture to and it’s messing me up. But, they didn’t, they are the ones who helped me download it.

I have a similar issue. I am new to Anki and just got V12 a few days ago. I synced to AnkiHub but it never loaded images. Specifically, I don’t see images in the text and extra fields, so I can’t answer questions. I see an image icon, but the images won’t load. Check media shows Missing files: ⁨3201⁩ and Unused files: ⁨2859⁩. I’ve tried resetting local changes, unsubscribing and resubscribing, and even completely deleting my decks and reinstalling Anki. Now I’m back at square one and still no images. Am I supposed to download images separately? Why am I still not seeing images?

The developers are updating the image sync process. See above reply by @jakub.f

Once they are done we will update you and then you will be able to see the images. Sorry about this

@Ahmed7 , I used Anking v11 for step 1, and recently subscribed (under gracious scholarship) for step 2. Can I use anking v11 APKG file to sync media for step 2 cards under AnkingOverhaul? going to Ankihub and Import media >> APKG file >> V11 apkg? I tried resetting local media, but the images are still unavailable.

1 Like

Yes you can do this if you included the media in the export as well. Note that the text and extra images are not included in V11 since they were replaced. These are only available through media sync through AnkiHub.

These images will all be available once the developers finish updating the media sync process. We will let you know when that occurs

I have v12 and am also having issues with media, it says media sync is idle. I tried resetting local etc. Is this a system-wide issue? Thanks